Сервер не смог выделить память из не выгружаемого пула памяти

При попытке использовать Windows 7 Professional как файловый сервер комп по сети становится недоступным, в событиях появляется о?ибка: «Сервер не смог выделить память из не выгружаемого пула памяти, так как достигнут указанный в конфигурации верхний предел»

Лечение:

В редакторе реестра переходим по адресу

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management в параметре LargeSystemCache устанавливаем значение 1.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanServer\Parameters в параметре Size устанавливаем значение 3.

Дать право пользователю запускать сервис.

Что бы дать права пользователю, луч?е всего воспользоваться утилитой SubInACL. Утилита входит в пакет Windows Resource Kits.

Запускаем cmd, переходим (команда cd) в каталог "C:\Program Files\Windows Resource Kits\Tools\"

Далее, в командной строке пи?ем subinacl.exe /service НАЗВАН?Е_СЛУЖБЫ /grant=ДОМЕН\ПОЛЬЗОВАТЕЛЬ=PTO

Выполняем команду.

 

Срисок ключей:

W : Generic Write
X : Generic eXecute
L : Read controL
Q : Query Service Configuration
S : Query Service Status
E : Enumerate Dependent Services
C : Service Change Configuration
T : Start Service
O : Stop Service
P : Pause/Continue Service
I : Interrogate Service
U : Service User-Defined Control Commands

Командный интерфейс. Проблема.

Командный интерфейс. Проблема.

Проблема: Был создан документ для и в включен в подсистему, но в командном интерфейсе, он упорно не желал отображаться.
111

Ре?ение. Нужно было включить галочку использовать стандартные команды.

222

Вот и всё.

333

Как оповестить форму о событиях в другой форме

Учебник 1С Как оповестить форму о событиях в другой форме

Для примера рассмотрим справочник "Страны Мира".

im5

У этого справочника есть несколько форм, в том числе ФормаСписка и Классификатор. Грубо говоря в форме классификатора содержаться сведения о всех странах.

im8

?з формы классификатора мы можем выбрать интересующую нас страну

im6

и поместить её в ФормуСписка.

im7Как же одна форма узнает о том, что происходит в другой?

Рассмотрим обе формы. В Классификаторе нас будет интересовать событие  "Выбор". Обратите внимание - это событие относится не к форме, а к основному реквизиту формы - таблице значений Классификатор.

im9

А в ФормеСписка событие так же основного реквизита Список (тип ДинамическийСписок) "ОбработкаВыбора"

im10

Процедура которая срабатывает при выборе из Классификатора называется КлассификаторВыбор.

&НаКлиенте
Процедура КлассификаторВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
    СтандартнаяОбработка=Ложь;
    ВсеДанныеСтроки = Классификатор.НайтиПо?дентификатору(ВыбраннаяСтрока);
    Если ВсеДанныеСтроки<>Неопределено Тогда
        ДанныеСтроки = Новый Структура(ПоляКлассификатора);
        ЗаполнитьЗначенияСвойств(ДанныеСтроки, ВсеДанныеСтроки);
       
        ДанныеВыбора =ДанныеВыбораЭлементаКлассификатора(ДанныеСтроки);
        ОповеститьОВыборе(ДанныеВыбора.Ссылка);        
    КонецЕсли;

КонецПроцедуры

Сообственно здесь нас интересует событие

ОповеститьОВыборе

?менно это событие закроет форму Классификатора и "сообщит"  ФормеСписка, что выбор произведен.

В ФормеСписка же отработает событие  ОбработкаВыбора  с процедурой СписокОбработкаВыбора. Которая просто обновит список.

&НаКлиенте
Процедура СписокОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    Элементы.Список.Обновить();
КонецПроцедуры